Turbo Snail behaviour

0 Members and 1 Guest are viewing this topic. 963 views

  • geordieboy
  • Posts: 21
  • Liked: 10
  • Thanks Given: 4
  • Received: 3
  • geordieboy
  • Location: Tyne and Wear

Hi all, came in this morn at 08-30 after a walk with my mutts and got a bit of a fright as my normally nice clear water was a bit misty looking. After a quick check on my Nem who was good i noticed 3 of my turbos all excreting a white fluid(guessing they're trying to fertilise females?) This went on for around 20-30 mins,got it on my ipad so will download here at weekend(busy at work at mo) Anyone seen same or any idea why/whats going on? Thanks.

Asco1104

  • Tim
  • Global Moderator
  • Posts: 2,657
  • Liked: 701
  • Thanks Given: 359
  • Received: 587
  • Location: Camberley
  • Tank Thread: https://reefbase.co.uk/members'-tanks-6/tims-first-and-last-upgrade/msg42396/#msg42396

Reply #1

Hi
Yes there reproducing, mine mainly did it if I stir the sand up. I have had baby’s to as a result.


Tim

fr499y

  • Global Moderator
  • Posts: 1,728
  • Liked: 524
  • Thanks Given: 70
  • Received: 329
  • Tank Thread: https://reefbase.co.uk/members'-tanks-6/fr499y's-4-footer-mixed-reef/

Reply #2

never seen them at it but had loads of babies before! was giving a load away at one point.

Tags:


Related Topics

3 Replies
750 Views
Last post Jul 4, 2015 7:28:53 pm
by Hai
3 Replies
1174 Views
Last post Apr 18, 2016 10:44:34 am
by HK_Fuey
6 Replies
1936 Views
Last post Apr 23, 2016 6:33:34 pm
by fishface
3 Replies
1451 Views
Last post Jun 6, 2017 11:34:09 pm
by HK_Fuey
4 Replies
915 Views
Last post Sep 13, 2017 8:34:26 pm
by Jay19


Donate towards the running of ReefBase

Donate £1.00 Donate £2.50 Donate £5.00 Donate £10.00 Donate £20.00 Donate another value