Urgent help Bubble Magus 5 P Skimmer stopped

0 Members and 1 Guest are viewing this topic. 844 views

  • Posts: 446
  • Liked: 54
  • Thanks Given: 51
  • Received: 20
  • Location: Manchester
My skimmer was working yesterday and In fact it wa producing too many bubbles very wet skim
Now nothing water is as calm as the sea o have took it apart and cleaned and the pump is pushing water in to the cone chamber but no bubbles are being produced! What has happened ??

Gav

  • Global Moderator
  • Posts: 2,016
  • Liked: 519
  • Thanks Given: 758
  • Received: 387
  • Location: Highlands
  • Tank Thread: https://reefbase.co.uk/members'-tanks-6/gav's-aqua-oak/

Reply #1

The air intake pipe could be choked ?

zollybosher

  • Posts: 446
  • Liked: 54
  • Thanks Given: 51
  • Received: 20
  • Location: Manchester

Reply #2

What is that please? I hat does it look like ?

Gav

  • Global Moderator
  • Posts: 2,016
  • Liked: 519
  • Thanks Given: 758
  • Received: 387
  • Location: Highlands
  • Tank Thread: https://reefbase.co.uk/members'-tanks-6/gav's-aqua-oak/

Reply #3

The rubber hose that goes onto the Venturi on the pump inlet pipe , also check the Venturi is clear .

zollybosher

  • Posts: 446
  • Liked: 54
  • Thanks Given: 51
  • Received: 20
  • Location: Manchester

Reply #4

Whooo there II don’t understand can you put it in simple terms their is a pipe that runs fromr an adaptor which fits on to the pump outlet are you talking about the actual pipe or the adaptor

Basically what has happened is that bubbles where  dissipating in the neck of the cone or In the collection head now they are not even getting to half way up the cone  and almost flat so no bubble head is present 😔

Gav

  • Global Moderator
  • Posts: 2,016
  • Liked: 519
  • Thanks Given: 758
  • Received: 387
  • Location: Highlands
  • Tank Thread: https://reefbase.co.uk/members'-tanks-6/gav's-aqua-oak/

Reply #5

Both , the adapter that pushes through onto the pump intake (the Venturi) and the hose attached (air intake) that goes up to the clear silencer bowl mounted beside the collection cup .

zollybosher

  • Posts: 446
  • Liked: 54
  • Thanks Given: 51
  • Received: 20
  • Location: Manchester

Reply #6

Thanks for that  :grin:  I have stripped it down and and cleaned the pipes and the inlet
The.skimmer produce more power now in that the bubbles go to the top of the cone but don’t break the noontime bet even the cone  and the collection cup no matter how much I adjust the intake  :s
Strange as yesterday know how much I adjusted the intake the bubbles  where flowing over the  cup

 But like I said the intakes are clear I can push  cleaning brush right through with no debris Do you think it’s tine to replace the pump or skimmer itself  I have had it about 18 months now and it pulls a lot it stuff  out




Gav

  • Global Moderator
  • Posts: 2,016
  • Liked: 519
  • Thanks Given: 758
  • Received: 387
  • Location: Highlands
  • Tank Thread: https://reefbase.co.uk/members'-tanks-6/gav's-aqua-oak/

Reply #7

Is the needle wheel impeller clear of any debris between the needles on the impeller inside the pump , this would also give similar problems as you described from previous day .

I've recently replaced my own skimmer , I went for a Deltec sc1456 quite some difference compared to the BM curve 5 I was previously running . Mine was a year old but upgraded as I've added more fish , was still going well before the swap over . But certainly not a patch on what the Deltec is pulling out for me now .

fr499y

  • Global Moderator
  • Posts: 1,683
  • Liked: 501
  • Thanks Given: 70
  • Received: 314
  • Tank Thread: https://reefbase.co.uk/members'-tanks-6/fr499y's-4-footer-mixed-reef/

Reply #8

But like I said the intakes are clear I can push  cleaning brush right through with no debris Do you think it’s tine to replace the pump or skimmer itself  I have had it about 18 months now and it pulls a lot it stuff  out

take the venturi intake section off the pump ( turn the grey locking nut on the pump housing and it should undo and pull off ) Chances are, theres a small bit of dirt in there stopping the air from flowing properly. Look at it from the pump side of the venturi adapter

Tags:


Related Topics

4 Replies
4037 Views
Last post Jan 3, 2015 5:43:21 pm
by Mike
1 Replies
2804 Views
Last post Jul 8, 2015 9:34:29 pm
by Mike
10 Replies
2738 Views
Last post Aug 7, 2016 10:47:17 am
by fishface
5 Replies
2828 Views
Last post Oct 27, 2016 11:48:44 am
by hixy
3 Replies
248 Views
Last post Aug 22, 2018 8:19:38 pm
by daniel04m